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1 New Import/Export Features 

1.1 Import MText as DFT Geometry 

cncKad now supports import of DXF files containing MText (where several paragraphs of text can 
be treated as a single text object) based on user defined font files (SHX extension). The text is 
completely imported as solid white geometry. 

This is the original MText text: 

 

When you import the file via the File menu => Import => Setup button, in the Parameters tab you 
can set Convert All Texts to DFT Font: 

 

The text is imported as regular geometric DFT text: 
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1.2 Convert Imported Text to Windows Font 

Geometry 

When you import a DXF file into cncKad or AutoNest, you can convert the text to Windows font 
geometry: 

 In cncKad, the path is via the File menu => Import => Setup button. 

 In AutoNest, the path is via the Part menu => Qty. Order => Import Setup button (or via 
the File menu => Save => New => Import Setup button). 

In the Parameters tab => Text Conversion section, specify Convert All Text to Windows Font, 
and select a default font from the Default dropdown list:  

 

If you check Keep Original Text, then cncKad also displays the original text. 

If the imported text comes with its own Windows font definition, then cncKad retains that definition 
and does not use the default Windows font.  

1.3 Filter Imported Files  

True for cncKad and AutoNest.  

When you browse for files in the Import File dialog box*, you can reduce the list of displayed files: 

 Type the character string for which you are searching.  

 Add a question mark (?) to indicate that there can be any character in that position. (Add 
two question marks for two characters, etc.) 

 Add an asterisk (*) when you do not know the length of the string.  

 For more details on the use of wildcards in regular expressions, search on the Internet. 

*To navigate to the Import File dialog box: 

 In cncKad: File => Import. 

 In AutoNest: Part => Qty. Order. 

For example, to see only the files that start with the text “door”, type door* in the file editing field (in 
the Folder Files section). 
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This picture shows the results of the filtering: 

 

1.4 Import Filter Editor 

You can now modify and merge existing filters. Following are examples of how to use these 
features. 

1.4.1 Create a Filter 

 This section explains how to set up the example. 

To set up a filter: 

1. In the File menu => Import, select a DXF file with layers and click OK.  

 You could also import a DWG file. 

In the Live Import dialog box, the colors look like this: 

 

2. Configure the layers with colors and line types as shown: 
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3. Click the Save As button and type the name Filter 1: 

 

4. Click OK. In the Live Import dialog box, click Cancel. 

1.4.2 Modify the Filter 

Modify the existing filter to suit a newly loaded DXF/DWG file with layers that are similar but not 
identical to the first file’s layers.  

To modify the filter: 

1. In the File menu => Import, select a DXF file with layers and click Setup button.  

2. In the Import Setup dialog box, click the Edit Layers Filter button.  

3. In the Edit Layers Filter dialog box, in the Editing Filter dropdown menu, select Filter 1: 

 

4. Click the Add Row button. In the table, add two rows as shown, so that CONTOUR2 
changes to white and 7 is hidden: 

 

5. Click Save and confirm. 

6. Click OK and confirm. 
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1.4.3 Merge Two Filters 

To merge two filters: 

1. Create a new filter by following the steps in section  1.4.1 and importing a different DXF file 
with layers. Call it Filter 2: 

 

2. In the Edit Layers Filter dialog box, in the Editing Filter field, select the first filter (Filter 1) 
from the dropdown list. 

3. Click the Merge Another Filter button. In the Layers Filter dialog box, select Filter 2 from 
the dropdown list: 
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4. Click OK. cncKad merges all the rows: 
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1.5 Change Color/Line Type  

From now on, when you import DXF or DWG files and you want to change the drawing to solid 
white, this change applies only to closed contours. 

This means that open contours that are colored or dashed do not change to solid white. 

To navigate to this option, go to the File menu => Import => Color Conversion tab => Convert 
All to Solid White. 

This example shows a circle and a line in an imported drawing: 

 

See that the circle changes to white but the line remains purple: 

 

1.6 Circles Smaller than Tolerance Are Not Deleted 

When importing a file into cncKad, anything smaller than the defined import tolerance is ignored. 
From now on, the cncKad import does not ignore circles, even when they are smaller than the 
tolerance size.  
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The tolerance size is defined in the File menu => Import, in the Import Files dialog box, click the 
Setup button. In the Import Setup dialog box => Parameters tab, the Import Tolerance field: 
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2 New Punch Features 

2.1 Improved Control of MicroJoint Tool on Nibbled 

Entity 

You can select the way MicroJoint (MJ) tools are placed on your part on the nibbled entity: 

 As the first or the last hit 

 As the second or second-to-last hit 

Open the Edit Punch dialog box by clicking the CAM menu => Edit CAM. (You can also do this in 
the Add Punch dialog box by clicking CAM => Punch CAM => Add Punch.) 

When you check the MJ Tool at Edge option, the MicroJoint hit is first and/or last.  

In this example, After First Hit is selected and MJ Tool at Edge is not selected, so the first hit of 
the MJ tool is the second hit: 

 

This is the result. You can see the first hit is followed by a MJ tool hit: 
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This is the result for the last MJ, when Before Last Hit is selected with MJ Tool at Edge. You can 
see that the MJ tool hit is the last punch hit:  

 

2.2 Select Unload Tool as Second Tool 

When you want to unload a part using a different tool than the one used to nibble an entity, you 
can define a second tool as the unload tool.  

There are two ways to get to this option: 

 In the CAM menu => Punch CAM => Add Punch, in the Add Punch dialog box. 

 In the CAM menu => Edit CAM, in the Edit Punch dialog box. 

Select Use Second Tool, and select Unload Tool from the dropdown list:  

 

You can then see the unload tool (indicated by a green U) next to the original tool on your entity, as 
shown in the following example: 
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 You can now set default settings for the second tool (whether MJ or unload) in the machine’s .MDL file. 
See details in the examp.mdl file in C:\Metalix\MACHINES. 

2.3 Identify Floating Scraps  

cncKad now can identify and warn when there are floating scraps. This is done: 

 Automatically at the end of AutoPunch  

 Manually, in the Post-Processor Options dialog box (in the Settings menu => Machine 
Settings, Post-Processor tab), when you select Check If Punch Destroys Neighboring 
Part and Floating Scraps: 

 

You can see the floating scrap in the middle of the picture: 

 

To stop checking for floating scraps, press the Esc key. 

2.4 Move Pickup Position of Second Tool 

You can change the position where the second (unload) tool is placed.  
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In the picture below, the second tool is in the default position (which is the offset of the unloader 
from the last hit with the nibble tool), marked by a U. 

 

To move the unload tool, click the second tool above the green U (unload indicator). It turns white. 
To place the unload tool on the part, drag the unload indicator to the new position. The Edit Offset 
dialog box opens. You can confirm the value or define a new one: 
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The unload arrangement appears again so you can select new active cups: 

 

2.5 Warn If Collision in Nest 

You can ask cncKad to issue a warning and not generate NC if a punch destroys a neighboring 
part: 

 

Set this option in the Settings menu => Machine Settings => Post-Processor Options tab, by 
selecting Check If Punch Destroys Neighboring Part and Floating Scraps. 

2.6 Change NC File Saves, Working Range, and 

Clamp Definitions 

If the machine model allows it, you can save a copy of the NC file to an additional location, and 
modify the default working range and clamp positions. These parameters apply to the active 
machine. 
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In the Settings menu => Machine Settings => Machine tab, click the Machine Definitions 
button: 

 

The Machine Definitions dialog box opens with several tabs: 

 

2.6.1 NC Send Tab 

You can configure how cncKad handles the generation of NC files. For example, you can make a 
copy of the NC file on a network drive with the extension of your choice. (By default, the NC file is 
saved locally, with the .?NC extension.)  
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Click the NC Send tab: 

 

Options: 

 Copy NC to Target Path – Creates an additional copy of the NC in the location defined in 
Target Path. When you check this option, the other options in this tab become relevant. 

 Remove Comments – Strips comments from this copy of the NC. 

 Ask for Confirmation – Requests you to confirm that you do want to create a copy of the 
NC. 

 Ask for Overwriting – Requests you to confirm that you want to overwrite the existing 
copy, if it exists. 

 Create Folder if Needed – If the folder named in the Target Path does not exist, cncKad 
creates it. 

 Copy NC Report Too – Creates a copy of the report as well as a copy of the NC. 

 Target Extension – Gives the NC file name this extension. By default, NC. 

 Target Path – The path to where the NC is copied. 

To cancel any changes you have made, click the Restore Manufacturer Defaults button. 

2.6.2 Working Range Tab 

You can set the working range of the machine. Your changes are stored in the MDLX file. 

Click the Working Range tab:  

 

To cancel any changes you have made, click the Restore Manufacturer Defaults button. 

2.6.3 Clamps Definitions Tab 

You can define the default settings and limitations for clamps for the current machine.  
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In the Clamps Definitions tab, this is what you can do: 

 Change the number of clamps. 

 Set the range of possible positions for each clamp in the Clamps Position Conditions 
table. 

 Set the positions of each clamp, depending on the size of the sheet, in the Fixed Clamps 
by Sheet Size table. 

 Restore the default positions by clicking the Restore Manufacturer Defaults button.  

The Fixed Clamps by Sheet Size section is not visible if your machine does not support this 
option. If it does support this option, you should see the Use Fixed Clamps Positioning 
checkbox. Check it and type your settings in the table. 

 These default settings provide the basis for the settings visible in the CAM menu => Set Sheet and 
Clamps => Clamps tab. 

2.7 Shear: Support per Part 

 For shear machines.  

cncKad now supports punch-and-shear operations, per part. It punches and shears each part 
separately. It also shears the scraps that must be cut and removed before the next part can be 
sheared. 

In the Nest menu => Set Sheet and Clamps => Sheet Processing Technology tab, define the 
Processing Strategy as Part. 

As shown in the example, blue tools apply to the whole sheet, and red tools only apply to the part: 
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Here you can see the CAMs for the whole sheet: 

 

See the punching of the first part in the simulation: 

 

This is how the simulation looks after the shear of the first part: 
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2.8 Crunch Arc Entity as a Whole Circle 

You can now crunch an arc using a circular crunch. In the Add Punch dialog box, select a round 
punch tool: 

 

The pictures show an example of how arcs are crunched (before and after): 
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2.9 AutoPunch Circles with Rectangular Extensions 

AutoPunch now supports shapes based on a circle with rectangular extensions.  

Examples prior to processing: 

 

Examples after processing: 
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2.10 Tools Setup Shown in Reports 

In AutoNest, there are two new punch reports: 

 The SubNest report includes the tool changes (from the basic setup) in the turret that are 
required to finish processing the SubNest. In the Settings menu => Report Settings => 
AutoNest Report Settings tab => SubNest Report section, select Use AutoNest 
DOC/TXT Report and then select the RPT_AN_SN_ENG_PUNCHTOOLSV15.doc 
template file: 
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 The Order Report displays a full tools turret setup file of all the stations, regardless of 
whether they contain tools. In the Settings menu => Report Settings => AutoNest Report 
Settings tab => Order Report section, select the 
RPT_AN_ALL_ENG_Portrait_04_PunchTools.doc template file: 
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3 New Laser Features  

3.1 Configure Material Cutting Defaults per 

Machine 

cncKad supports a default setup of material cutting parameters for each machine separately. 

Open the Cutting Technology Table (by clicking the CAM menu => Cutting Table) and click the 
Material Cutting Defaults button: 

 

The Material Cutting Defaults table contains default values for gas, head, and lens for each 
cutting technology material: 

 

3.2 Import Machine Cutting Technology Tables  

cncKad allows you to import cutting data from the machine environment in various file formats into 
the internal cutting technology tables. 

 Relevant for Mitsubishi, Boschert, Bystronics, Durmazlar, and Prima laser machines. 
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This is the typical procedure for importing a cutting technology table: 

5. In the Settings menu => Machine Settings => Cutting Parameters tab, click the Import 
Cutting Tables button. This is how the Import External Cutting Table dialog box might 
look: 

 

In this table, map your machine material names with the cncKad cutting technology table 
material names. 

6. Click the browse button  next to the Folder field. 

7. Navigate to the cutting data folder or file (depending on the machine/manufacturer type) to 
import and click Open. 

8. Click the Validate button. cncKad validates the cutting data and produces a full report of 
the validation results. It appends all the unrecognized material names into the Material 
Names Mapping table.  

9. View the created log file and set the appropriate mapping of all the new material entries (if 
any) that were created in the mapping table. This is done by clicking the dropdown lists in 
the cncKad CT Material (CT = Cutting Technology) column, next to the entries in Name on 
Machine column, and selecting the correct mappings. 

10. Click the Validate button again. 

11. Check that the validation process worked correctly by examining the log file: Click the View 
Log File button and look for problems and warnings: 

 

12. Run the import process by pressing the Import button. 
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3.3 Support Dropdown Selection in Cutting 

Technology Tables 

You can define some of the columns in the cutting technology table as dropdown lists. This allows 
the user to choose from the options in the dropdown list. This feature is only available for columns 
named Mode1 and Mode2 (visible in the INI file). 

To configure a column as a dropdown list, edit the TITLES.INI file for your machine: 

1. In the Settings menu => Machine Settings => Machine tab, click the Machine Settings 
button. 

2. In the Machine Settings dialog box, from the Edit Machine Files dropdown list, select the 
*_TITLES.INI file. 

3. Click the Edit button: 

 

4. In the [DropDownCutting] section of the file, add the lines you need and save the file. 

For example: 

[DropDownCutting] 

Mode1 = 0:0 1:1 

Mode2 = 0:No Cut_B 1: Standard_B  2: High qual 13:Speed_13 4:  Special Mode 
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In this case, the table looks like this (in the Cutting Technology Tables dialog box, in the Cutting 
tab): 

 

3.4 Improved WireJoint Control in Common Cuts  
 WireJoints are a type of MicroJoint. 

cncKad has two new options for defining WireJoints for common cuts: 

 No WJ when entity length is below – cncKad does not place a WireJoint when the length 
of the entity is smaller than the defined length. 

 Only 1 WJ when entity length is below – cncKad only places one WireJoint when the 
length of the entity is smaller than the defined length. 

In the CAM menu => Cut CAM => AutoCut => AutoCut tab => Common Cut section, select 
Perform, and click the Settings button. The Common Cut Parameters dialog opens:  

 

See the WireJoints in the red circles in the following picture: 

 Entities longer than 200 have WireJoints on the left and in the middle. 

 Entities between 50 and 200 have one WireJoint. 

 Entities shorter than 50 have no WireJoints. 
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3.5 Make Corrections to Circles  

You can refine circle cutting using the circular hole technology parameters. Select between: 

 Slowing down at the end of cutting the hole 

 Adding a bump to the end of the hole 
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To set these parameters: 

1. In cncKad, in the CAM menu => Cut CAM => Add Cut, check the Holes Technology 
checkbox: 

 

 This option is also available in the CAM menu => Cut CAM => AutoCut, in the AutoCut tab, by 
clicking the Settings button in the Holes Technology section. 
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2. The Holes Technology Parameters dialog box opens. Select one of the following options: 

To slow down the last part of the circle 
cutting, select Use Slow at End and type 
the values that apply. 

To define a bump, select Use Circle 
Correction and type in the values that 
define the bump: 

  

3. Click OK. 

3.6 Display Machine's Grill Geometry Background 

In cncKad and AutoNest it is now possible to create and display the grill geometry representation 
of the current model as the background of the current view. This feature is supported for all sheet 
view types.  

To create a grill: 

1. Create a DFT file with the desired grill drawing. The grill should extend beyond the borders 
of the working range on all sides. Here is an example of a grill DFT: 
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2. In the Settings menu => Machine Settings => Machine tab => Machine Definitions 
button => Grill Definitions tab, click the Save Current Drawing as Grill button:  

 

3. In the Grill File dialog box, type a file name and click Save. The saved file will have a 
GRILL extension. 

To use a grill: 

1. In the Settings menu => Machine Settings => Machine tab => Machine Definitions 
button => Grill Definitions tab, in the Active Grill field, select the grill name from the 
dropdown list. 

2. Determine how brightly to display the grill by setting the value in the Brightness field: 

 

This is a part opened on a grill: 
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4 New: AutoNest Pro 

AutoNest Pro is a new addition to AutoNest. It includes an automatic nesting algorithm that 
greatly improves both nesting quality and speed. 

 AutoNest Pro is a separate module, sold for an additional charge. 

After adding AutoNest Pro option to Hasp key, you can enable it in the Settings menu => 
Workspace Settings => AutoNest tab: 
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When you select Start/Continue AutoNest (from the Nesting menu), you can see that there are 
new options for arranging the parts on the nest: 

 

AutoNest Pro: 

 Gives the most efficient arrangement of parts on the sheets. 

 Gives you full control over the running time. 

 Supports a minimum number possible of SubNests, when you check the Minimum 
Number of SubNests Mode option.  

 During nesting, shows multiple sketches of the proposed nests:  

 

 Allows you to stop the nesting when you see a satisfactory result.  

You can return to the old method by selecting Use AutoNest Standard option in the Settings 
menu => Workspace Settings => AutoNest tab. 

The following example compares standard overnight and the same .DSP file with AutoNest Pro 
results. 
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Standard AutoNest: 

 

AutoNest Pro: 
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5 New in AutoNest 

5.1 Use Newer DXF Files 

You can make sure you are using the most recent DXF files when validating a daily job in 
AutoNest. In the Edit/Extend Order dialog box (accessed from Part => Qty. Order), check the 
Use DFX If Newer checkbox so that AutoNest re-imports DXF files if they are more recent than 
the DFT file: 

 

5.2 Ask Feature  

You can now get information about the items in your AutoNest display area, in the same way that 

you get information in cncKad. Click the Ask icon  (or press F8). The cursor changes to a 
question mark. Click an entity in the display area. AutoNest opens a small window in the top left 
corner with the relevant data, for example: 

 

To see information on another entity, click anywhere in the display area. The window stays open 
until you close it. 
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5.3 Get Part Information and Instance Data  

Two new options are now available in AutoNest, accessible from the SubNests toolbar 

:  

 When you click the Get Part Information icon  and click an instance of a part in the 
nest, AutoNest selects all the instances of this part and opens the Nest Data dialog box:  

 

Continue clicking parts to see the relevant summarized information. 

 When you click the Get Instance Data icon  and click an instance of a part in the nest, 
the Nest Data dialog box opens, displaying more information: 

 

 You can control the level of information displayed in this dialog box by clicking the plus and minus 

signs  at the start of each line. 
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5.4 Create Buffer Tables per Machine 

AutoNest supports the creation and maintenance of buffer data tables for each machine model. 
A Buffer Table contains the part and hole buffer values for each material & thickness combination 
for the active machine. 

Click the Buffer icon  on the CAM toolbar to open the buffer table: 

 

5.5 Define System Origin 

In AutoNest you can now define the default starting point of the nest. 

In the Settings menu => Machine Settings => Machine tab, select one of the options for System 
Origin: 
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This is how the sheet looks in AutoNest with the above settings: 

 

5.6 Set Start Corner and Optimization Path for 

Tools 

In AutoNest you can now define the starting corner and optimization path for specific tools: 

1. In the Settings menu => Machine Settings => NC Options tab, click the Add Tool Rule 
button: 
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2. In the Tool Selection dialog box, select a tool and click OK:  

 

3. In the NC Options tab, in the Tool Order Rules section, click the Optimize Path column 
on the right: 

 

The Tool Data dialog box opens: 

 

4. Select Tool-specific Optimization. Select a starting corner and an optimization path from 
the dropdown lists and click OK.  
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The example below shows definitions for three specific tools: 

 

The only way to override the rules is during NC generation. In the Used Tools dialog box, you can 
change Order/Optimize, and continue to generate the NC.  

However, the next time you open the Used Tools dialog box, the rules will be applied again.  

5.7 Multiply Part Instances Using Mouse (Dynamic 

Grid) 

You can use the mouse to nest instances of a part in a specific area of your nest. 

For example, place one instance of a part on your nest. Click it. A small blue square appears on 
the bottom right of the part: 
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Click the blue square and drag it down and right to define a temporary rectangle (thereby creating 
a dynamic grid) to hold all the part instances. When you release the mouse, AutoNest fills the 
rectangle with as many instances as it can, up to the maximum number of instances defined: 

  

5.8 Use Empty SubNest 

When you run Start/Continue AutoNest (for example, by clicking the icon ) and you already 
have an empty SubNest, AutoNest uses it and does not start a new SubNest. 

5.9 Support Tooling in AutoNest 

You can now view and manipulate the tooling from within AutoNest with the new CAM menu.  

5.9.1 Display Tooling 

To change to the tooling view, at the bottom left of the screen, click the Regular View button 

:  
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The display changes to the cncKad view in a graphic screen: 

 

Trim sheet (for punch machines), split sheet, and cut sheet are now visible dynamically, and 
reflected in the Used Tools dialog box. 

To revert to the usual AutoNest view, click the Tooling View button . 

Many display options are now available in AutoNest. 

From the View menu: 

 Show End Points 

 Full Cut Tool Width 

 Rapid Tool Path -- toggle the view of how the head travels between three different levels 
of detail: showing holes (All), parts (Only Parts), or neither (None). Click Alt+B to toggle 
between the levels. 

 Multi-Color Tools 

 Fill Tools 

 View Die Modes – for punch machines 

 Color Tool Path by Speed -- for laser machines, you can change the display to see tool 
path speeds in different colors  

 Show Bend Lines 

 View Push Out Mode 

From the Part menu, you can now Show Active Cups for part unloader. 
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5.9.2 Manipulate CAM View 

In AutoNest, you can make changes to the CAM. This was previously only possible in cncKad. 

Most of these functions are available from the CAM menu, when you are in the tooling view. 

You can make the following changes (depending on your machine type): 

 For punch machines only:  For laser machines only: 

 Make changes in the Used Tools dialog 
box in a nest: changing the tools and 
tool data, selecting a turret setup file, 
adding tool functions, etc.: in CAM menu 
=> Used Tools. 

 Drag punching, and change MicroJoints. 

 Control pickup: see moving the pickup 
position. 

 Change MicroJoints: in CAM menu => 
Cut CAM => MicroWeld/MicroJoint => 
Add/Edit/Delete/Move. 

 Change the lead-in (entry): in CAM menu 
=> Cut CAM => Edit Contour Entry. 

 Apply the smart cut: in CAM menu => 
Smart Cut. 

When using both punch and laser machines, you can edit and delete CAMs (in the CAM menu) 
and change the CAM processing order. 

5.10 Apply Smart Cut 

Smart Cut allows you to apply automatic changes (to parts entry and MicroJoint part handling) to 
the SubNest. 

 Smart Cut is only available with laser machines. 

In the CAM menu, select Smart Cut. The following dialog box opens: 

 

You can make changes to the part entry point by selecting an option from the Side dropdown list or 
from the Corner dropdown list. 

You can also make changes to the part handling by checking Run PH for MicroJoints, clicking 
the Part Handling (PH) button, and editing the data in the dialog box. 

5.11 Nest According to Turret Restrictions 

 This feature only applies to punch machines. 

AutoNest now arranges parts on the SubNests, taking into account the tools in the turret, their 
indexes, the number of stations, and the station sizes.  

For example:  

1. AutoNest adds a part from your order to the first SubNest, based on the tools that can be 
added to the turret.  

2. AutoNest continues to add parts.  

3. When AutoNest encounters a part and cannot add the tools needed for the part to the 
turret, it places that part on a new SubNest. 
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To tell AutoNest to consider the turret restrictions: 

1. Click the Start AutoNest icon .  

2. At the bottom of the Start/Continue AutoNest dialog box, click the Advanced button.  

3. In the General tab, check the Turret Based Nesting option and click OK: 

 

Your preference is saved. 

5.12 Create Common Cuts Dynamically 

 This feature only applies to laser machines. 

AutoNest can now indicate common cuts dynamically, as you work. Now there is no need to 
create the NC when you want to see the common cuts. 

In the View menu, make sure you select Show Common Cuts: 

 

As before, a pink line indicates common cuts between parts. 
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Here you can see a part at a distance from  
the other parts:  

Here are common cuts between all the 
parts: 

  

5.13 Create CAM Layers 

By default, AutoNest processes the single CAM layer. You can add CAM layers for a machine and 
then tell cncKad to process a particular layer of the geometry: 

1. In the Create Order dialog box (shown when you select New from the File menu), add 
some parts.  

2. Select one of the parts and check the Create New CAM Layer(s) option: 
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3. Click the AutoCut (or AutoPunch) button and select All. Click Auto, and close the 

Operation dialog box. In the Create Order dialog box, click the Edit button . 
cncKad opens. 

4. In the State Bar on the left of the cncKad main screen you can see the two layers: 

 

5. From the dropdown list, select the layer you want to view. 

5.14 Add Tooling When Exporting SubNest to DFT 

When you want to save the current SubNest as a DFT file and open it in cncKad, AutoNest asks 
you if you want to save the tooling data as well. 

To do this: 

1. In AutoNest, in the Machine menu => Machine Settings => AutoNest tab, check Offer to 
Generate DFT with Tooling: 

 

2. Click OK. Click the Open Current Nest as DFT in cncKad icon . AutoNest then 
shows you this dialog box: 

 

3. Click Yes. 
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5.15 Confirm Overwrite 

Two new confirmations are required before overwriting existing files: 

 When you export a SubNest to NST or DFT file -- If such a file already exists. 

 When you create a new order file – If it has the same name as an existing DSP file (and 
there is no corresponding ORD file). 

Sample confirmation dialog box: 

 

5.16 Right Click to Preview Part 

When you highlight a part in the Parts Bar and right click the mouse, you can see the Preview 
option: 
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The preview window opens, for example: 

 

5.17 Define Max. Blank Size for Busbar 

 For busbar machines only. 

You can now define the maximum size for blanks in busbar machines. 

For example, in the Create Blank Parts dialog box (in the Nesting menu => Blank Parts => 
Create Blank Parts), set: 

 Size of Blank to Keep to 1000mm 

 For Blanks below Size to Keep, Max. Length of Blank to 300 mm 

If the remaining scrap is bigger than 1000mm, AutoNest creates one blank and keeps it whole. 

If the remaining scrap is smaller than 1000mm and bigger than 300mm, then AutoNest creates 
several same-size blanks, with size smaller than 300mm. 

If AutoProcess is set, AutoNest processes each blank automatically. 
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5.18 Use Part Handling Table for Blank Processing 

You can cut blanks using the Part Handling table. 

1. In AutoNest, under the Nesting menu => Blank Parts => Create Blank Parts, in the 
dialog box, select Use AutoProcess:  

 

2. In the Blanks Unloading section, click Use Part Handling and the Part Handling Table 
button: 

 

5.19 Show Split Skeleton, Reposition, and Clamp 

Only When Relevant 

When the current machine does not support split skeleton, reposition, and clamp, AutoNest does 
not show these options. 
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5.20 Sort AutoNest Order Report by Selected 

Columns 

When generating the Order Report, it is now possible to sort the report data by two columns, for 
primary and secondary sorting. Select the desired columns in the Settings menu => Report 
Settings => AutoNest Report Settings tab => Sort by Columns section.  

You can select from among the columns visible in the table in the Edit/Extend Order dialog box: 

 

For example, sort the columns by material and then by thickness: 

 

The Order Report shows the parts sorted by material and thickness (in the Parts in SubNests 
section): 

 

5.21 Support Minimum Size when Printing Shapes  

In cncKad, you can define a minimal pixel size for part images when printing Microsoft Word 
reports in AutoNest.  
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Do this in cncKad in the Settings menu => Workspace Settings => Printing tab: 
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6 Improved Estimation Data in AutoNest  
When you edit or view a daily job in AutoNest you can see a detailed view of the entire estimation 
data of the active daily job.  

 Relevant only for laser machines. 

The Daily Job Estimation view provides summarized information on three levels:  

 For the entire daily job 

 Per material and thickness combination 

 For every part  

You can actually view a subset of the estimation data even before you run automatic nesting, after 
you create the daily job and process the parts with AutoCut.  

See the initial estimation via the Estimation menu => Daily Job Estimation. The following 
example shows three different material-thickness combinations: 

 

To see more detail, add cost data in the Estimation menu => Estimation Settings dialog box (just 
like in cncKad). Examples: 

 Add costs per pierce in the Additional Time Constants tab, in the Global Costing Rates 
section: 
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 Add cost for gas in the Gas Prices tab: 

  

Once you have processed some or all of the parts, you can see the calculations. In the Estimation 
menu => Daily Job Estimation dialog box: 

 View all the estimated costs. 

 Filter the estimation data, displaying data only for the nested parts, by checking Include 
Placed Parts Only.  

 By default, the estimation displays the cost for the total number of each part. Display the 
detailed cost estimate for single parts by checking Show Single Part Columns. 

 View a preview of the currently selected part by checking Show Preview in the Daily Job 
Estimation dialog box. 

This is how all these options selected together might look: 

 

You can create a report of the estimated costs: 

1. Select a report template -- In the Settings menu => Report Settings => Daily Job 
Estimation Report tab, select a report template from the File Name dropdown list and 
click OK: 

 

 You can make changes to the template by clicking the Edit button. 
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2. From the Estimation menu, select Daily Job Estimation. In the Daily Job Estimation 
dialog box, click the Estimation Report button:  

 

Your report opens automatically. Below is a sample report: 
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cncKad 

 
58 

7 New Ribbon Interface  
The cncKad and AutoNest interfaces now include modular ribbons. 

In the Settings menu, select Ribbon Mode. The ribbon interface opens. The options in the ribbon 
change, depending on what you are working and the tab you select (3). 

In a typical ribbon in cncKad, this is what you might see: 

 

In a typical ribbon in AutoNest, this is what you might see: 

 

These are the sections in the ribbons: 

(1) Options often found in the File menu, including New, Open, Save, Print. 

(2) The Quick Access Toolbar. 

(3) Tabs. As you select different tabs, the options in the ribbon change. 

(4) A group:  

 In the cncKad example, the Start group contains options for Ask, Measure, Sheet and 
Clamps, etc. 

 In the AutoNest example, the SubNests group contains options for New SubNest, Delete 
SubNest, Delete All, etc.  

 Can also contain dropdown menus. 

To revert to the toolbar interface, in the Settings ribbon, click the Toolbar Mode icon . 

7.1 Managing the Quick Access Toolbar 

You can situate the Quick Access Toolbar above or below the ribbon. Right click the Quick Access 
Toolbar and select Show Quick Access Toolbar Above/Below the Ribbon. 

To add an option to the Quick Access Toolbar: 

 Right click the icon in a group on the toolbar and select Add to Quick Access Toolbar: 
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 Right click a ribbon and select Customize Quick Access Toolbar. Choose from where to 
select a command, find the command, click Add and OK: 

 

7.2 Customizing the Ribbon 

You can add and delete icons from a ribbon. Right click a ribbon and select Customize the 
Ribbon. Choose from where to select a command, find the command, click Add, and OK. 

 

To revert to the default ribbon interface, in the same dialog box, click the Reset button. 
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7.3 Creating Tabs and Groups 

You can create your own tabs and groups, and add icons to them. 

Right click a ribbon and select Customize the Ribbon. Click the New Tab or New Group buttons: 

 

Select one item at a time from the list on the left and click Add to add to the new tab/group. 

Give the new tab/group a meaningful name by selecting it, clicking the Rename button, and typing 
a name: 

 

7.4 Minimizing the Ribbon 

Right click a ribbon and select Minimize the Ribbon.  

To maximize it, right click anywhere at the top of the screen and deselect Minimize the Ribbon. 
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8 New in ORD/CSV Processing 

8.1 Create Remaining Parts Order in AutoNest 

You can create an order file (.ORD) that contains all the remaining parts of an existing daily job. 
This command works also for daily jobs for tubes, busbars, etc. 

Select the Create Remaining Parts Order option from the File menu: 
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The Create Remaining Parts Order dialog box opens. Type a file name: 

 

AutoNest automatically adds _REMAIN to the file name so it does not overwrite the file you have 
already saved. 

8.2 Save Daily Job Data without Exiting Dialog Box 

In AutoNest, when working on a daily job, you can apply and save all the changes without exiting 
the Create Order dialog box.  

In the Create Order dialog box (shown when you do File => New, etc.), click the Save ORD 
button:  
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The following message appears: 

 

Click the OK button to return to the Create Order dialog box (Daily Job). 

8.3 Save Current Daily Job as ORD File  

You can save the current daily job as an order file, no matter how it was loaded: as an ORD, CSV, 
or confirmed daily job (DSP) file.  

 AutoNest saves the entire daily job, even if the part list was open for a specific 
material. 

To save as ORD, in the Edit/Extend Order dialog box (accessible via the Part menu => Qty. 
Order), click the Save ORD button below the part list: 

  

8.4 Enable Zero Value for Part Quantity 
 This option is helpful for supporting filler parts, and applies to both CSV and ORD file types. 

When you create a daily job order in AutoNest, you can now set zero as the minimum part 
quantity. In this way, filler parts are included in the order but are only nested after you finish nesting 
the main parts.  

 When loading a CSV order file, if the minimum quantity is zero, then the maximum 
quantity must be specified as GREATER than zero. 
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9 New in Tubes 

9.1 Import Tube Parts from DXF Files 

cncKad allows you to import tube parts from DXF files. The DXF must contain a valid geometry of 
the unfolded tube part; otherwise, the result is unpredictable. 

In the Import Files dialog box (accessible from the File menu => Import), in the File Extension 
section, select AutoCad (*.dwg, *.dxf). In the Part Type section, select Tube: 

 

9.2 Improved Tube Link  

CAD Link now imports tubes to cncKad without flattening (unfolding) them. It also imports tubes 
with open rectangular profiles. 

9.2.1 Import Tubes without Flattening 

CAD Link can import tubes to cncKad without flattening (unfolding) them, making the import 
process faster and less prone to errors.  

Supported profiles may be rectangular, circular, elliptical, obround, and custom. (Custom profiles 
are any closed freeform profile.) 
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In addition to importing the outer surface, for more precise cutting you can now import the inner 
surface. In CAD Link, select the Export Outer and Inner Surface option in the Tube Profile 
dialog box (accessible when you click the Tube Export icon): 

 

You can set Export Outer and Inner Surface as the default in Global Settings => Tubes in the 
Solid programs: 
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9.2.2 Export Open Rectangular Profiles 

CAD Link can export tubes with the following open rectangular profile: 

 

To use it: 

1. In CAD Link, click the Tube Export icon. In the Tube Profile dialog box, select the 
Rectangular Profile and check the Special Tube Profile option as shown: 

 

2. Click OK. The Tube Parameters dialog box opens. Type the height for this profile: 

 

 The height is highlighted in red because this is the only field that is not imported, so this is the field 
you will be most likely to change. All the other fields are imported, and you can change them. 

3. To complete the export, click OK. 
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9.3 View Tube Simulation in 3D 

cncKad now supports 3D simulation for tubes.  

 3D simulation is already available for Hans and Mitsubishi machines.  

To see 3D simulation on other machines, add the following key to the machine MDL file: 

[3DSimulation] 

Sim3DFileName=<SimulationFilename.xml> 

In cncKad, in the Tube menu, choose the 3D Simulation option: 

 

The tube’s 3D Simulation screen opens: 
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Here you can watch the tube cutting simulation in 3D, including tube rotation and laser head 
movements: 

 

9.4 Create Elliptical Tubes 

You can now create elliptical tubes in cncKad.  

Go to the File menu => New => New Tube, and in Profile select Elliptical from the dropdown list.  

This is an example of an elliptical tube created in cncKad: 

  

9.5 Create Obround Tubes 

You can now create obround tube parts in cncKad.  

In the File menu, select the New Tube option, and in Profile select Obround from the dropdown 
list. 
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This is an example of an obround tube created in cncKad: 

   

9.6 Create Angle and Channel Tube Profiles  

cncKad now supports these tube profiles: 

 Angle profile (L shape): 

      



cncKad 

 
70 

In 3D simulation: 

 

In cncKad: 

 

A different angle profile 

 

 Channel (U shape): 
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9.7 Support Flexible Tube Clamping Techniques 

cncKad now supports Trumpf RotoLas machines.  

When you work with tubes, you can use any number of clamping techniques, according to the 
settings in the machine model file (.MDL). The picture below shows available clamping techniques 
such as Turning Jaws and Drilling Jaws (from the Tube menu => Settings): 

 

Pick the one you want. 

In addition, cncKad supports additional parameters in the MDL file for each clamping technique 
such as the name on the machine. 

9.8 Move Tube Supports 

 This feature applies specifically to Trumpf RotoLas III machines. 

You can move the tube supports as often as required and in any direction. 

In the Tube menu => Move Support, select Define Support Movement: 
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This picture shows two supports: 

  

To delete the tube supports movement, in the Tube menu => Move Support, select Delete All 
Supports Movement. 

9.9 Allow Dead Zone for Circular Tube Supports 

cncKad now allows an automatic dead zone for supports of circular tubes. 

9.10 Generate Common Cuts for Tubes 

AutoNest can now generate common cuts automatically for any shape tubes, when the distance 
between tubes is exactly the thickness of the beam (determined by the buffer in AutoNest). 

Select Automatic Testing of Common Cuts as the default in the Settings menu => Machine 
Settings => Post-Processor Options tab:  

 

The picture shows the common cuts in pink: 
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9.11 View Custom Tubes in 3D View 

You can now use cncKad’s three-dimensional (3D) view to examine custom tubes. Custom 
profiles are any closed freeform profile (either imported or generated in cncKad). 

In cncKad, in the Tube menu, choose the 3D View option. 

For example: 

 

9.12 Add 3D Part Preview to Reports 

You can add a three-dimensional preview of the part to your reports. It is relevant both for single 
parts and for nests. 

This sample report was created for a single part, with a new token added at the top: 
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10 New in Post-Processing 

10.1 Run Part Handling for MicroJoints 

 Only relevant for cutting machines. 

You can run part handling (PH) only for MicroJoints. When you do, cncKad removes any existing 
MicroJoints on the parts, and configures the parts according to the PH definitions. 

To do this, when generating NC, in the Post-Processor Options dialog box, check Run PH for 
MicroJoints: 

 

To activate or edit the part handling settings, click the Part Handling button: 

 

You can set cncKad to run PH for MJ as the default. In the Settings menu => Machine Settings 
=> Post-Processor Options tab, indicate your choices, and check Run PH for MicroJoints. 
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10.2 Test Common Cuts for Rectangular Tools of 

Same Height 

cncKad now automatically tests common cuts for different rectangular punch tools that have the 
same height (the same Y). cncKad chooses one of the tools and creates a common punch, 
recalculating the MicroJoints. 

10.3 Support for Finn-Power Tulus Controller  

cncKad supports the option to display part geometry on the Tulus controller. 

10.4 Allow Reposition and Transformation for 

Trumpf  

cncKad allows reposition and transformation for newer Trumpf machines. 

10.5 Change Entry Point during NC Creation 

In AutoNest, you can now change the entry of all parts, both for regular nests and tube nests. 

During NC generation, in the Cutting Optimization dialog box, a new section contains the options. 
This is how the dialog box looks for regular nests:  
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For regular nests, select options from the Side and Corner dropdown lists: 

  

For tube nests there are only options for Side. 

The options are also available in the Settings menu => Machine Settings => Cutting 
Optimization tab, where you can set general defaults for the current machine.  
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11 New General Features 

11.1 Rotate Remnant 90 Degrees 

You can rotate a remnant in the sheet size database.  

In the Settings menu => Workspace Settings => Material tab, click the Sheet Database button. 
The Sheet Sizes dialog box opens. Select any shaped remnant and click Rotate 90: 

 

This is how the remnant looks after rotating it once by 90 degrees: 
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11.2 Create a Remnant and Open It in AutoNest 

This feature allows you to add existing remnants to the sheet database. You do this by creating a 
remnant in cncKad and then opening it in AutoNest. 

These are the steps: 

1. Create a part that has the dimensions of a remnant you already have. For example: 

 

2. From the CAM menu, select Add Remnant to Material Inventory, click the contour, and 
press the Enter key. The Remnant Properties dialog box opens.  

3. Check Create Daily Job Order, type a value greater than zero into the Quantity field, and 
click OK.  
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You can then see the remnant in the Sheet Sizes dialog box: 

 

cncKad opens AutoNest automatically, with the remnant as the current sheet: 
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11.3 Change TITLES.INI File According to Active 

Language 

You can use different TITLES.INI files for different languages. cncKad selects the relevant file 
automatically according to language selection in cncKad and the file name.  

For example, suppose the customer is using an Amada machine and wants to use both French 
and English titles for table headers (e.g., in the Cutting table) using the AMADA_TITLES.INI file. 
One TITLE.INI file must be created in the Machines folder for each language:  

 AMADA_TITLES_FRE.INI  

 AMADA_TITLES_ENG.INI  

When the customer switches languages (in the Settings menu => Languages), cncKad 
automatically selects the appropriate file (if it exists), with no need to re-select the machine.  

You can see the two different TITLES.INI files in the Settings menu => Machines Settings => 
Machines tab => Machine Settings button => Edit Machine Files dropdown list: 

 

11.4 Save Sub-Part with All CAM Layers 

In cncKad, you can now save a sub-part file including all its CAM layers: 

1. Open a part that has more than one layer.  

2. In the File menu, select Save Sub-Part.  

3. Click all the entities to save, press the Enter key, and type a file name.  

cncKad saves the sub-part as a DFT file with all CAM layers assigned to it.  
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11.5 Show/Hide Columns in Material List 

When you open the Material List dialog box (via the Settings menu => Workspace Settings => 
Material tab => Edit Material List button), the dialog box initially shows a reduced set of columns 
(generally considered the most common used). To show the hidden columns, click the right arrow 

 at the bottom right of the dialog box:  

 

This is an example of more columns. To see fewer columns, click the left arrow : 

 

11.6 Mirror and Grain Direction in Material List 

The Material List dialog box has new columns: 

 Mirror OK – Specifies if parts made from this material can be mirrored; i.e., both sides of 
the material are identical. Options: Yes/No. 

 Grain Direction – Yes indicates that parts made from this material are restricted to 
rotations of 180 degrees. This means that if the available directions are four-way, only two 
ways are allowed. No means that parts can be rotated in any direction. 
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You can see/edit these columns’ values by clicking the Settings menu => Workspace Settings 
=> Machines tab => Edit Material List button: 

 


